IRIS 2.4 and compatible Dive Computers list.
Posted by Support Manager, Last modified by Gianluca Tedone on 20 June 2012 05:30 PM
Recently we received several request about issue with IRIS 2.4 and some Mares dive computer models.

IRIS 2.4 is only compatible with NEMO dive computer model family.

If you own previous models (Airlab, M1, M2, Darwin), you must install IRIS 2.3 release.
(326 vote(s))
Helpful
Not helpful

Comments (0)
Post a new comment
 
 
Full Name:
Email:
Comments:
CAPTCHA Verification 
 
Please complete the below captcha challenge (we use this to prevent automated submissions).

Powered by 21Style